Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.

...

...

...

...

SmartServer Pi is available with SmartServer 4.2 and higher.

With SmartServer Pi, you can create a SmartServer on a Raspberry Pi 4 or Raspberry Pi Compute Module 4 (CM4) hardware. SmartServer Pi is a collection of software containers that you can run on ARM Linux platforms that are compatible with a Raspberry Pi 4, including any platform with a Raspberry Pi CM4 and Raspberry Pi OS. SmartServer Pi is compatible with Raspberry Pi OS 11 (Bullseye). For platform requirements and installation instructions, see Step 1 - Installing SmartServer Pi

You can set the processes running in the SmartServer Pi containers to share the same network as the rest of your Pi, but isolate the SmartServer containers in the process name space. With this setup, each process has the impression that it is the only process running on the system.

SmartServer Core license is required to provide core SmartServer functionality. The Core license supports BACnet, EnOcean, LoRaWAN, and Modbus TCP and RTU device interfaces,  device discovery, device import, and device creation; LON is not supported. This license does not expire. See Managing Licenses for SmartServer Pi for more information. 

This section describes how to get started with SmartServer Pi and consists of the following:

...